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Upgrade OneStream XF 6.3.1
Use this procedure when upgrading from an earlier OneStream XF release to 6.3.1. The anticipated
audience for the upgrade process is Information Technology professionals responsible for installing,
maintaining and supporting OneStream XF.

Review the following OneStream XF 6.3.1 requirements prior to scheduling an upgrade and any related
notes in the OneStream XF Installation and Configuration Guide, available on XF MarketPlace.

1. If upgrading from OneStream XF version 5.3.x or earlier, it is required to update OneStream to
.NET 4.7 for Microsoft’s security standards and for advanced features to stay current on the latest
version of the .NET Framework. 

Note: Microsoft provides the .NET Framework 4.7 optional update through standard Microsoft
Windows Updates. 

Important: The most recent database schema update was 6.2.0. You will need a database
schema update if upgrading from 4.2.x, 4.3.x or 5.2. or 6.0 to version 6.30. We recommend full
database backups.

2. The 6.3.1 version of the OneStream Studio and OneStream Excel Add-in are not backward-
compatible with versions up to 5.x. You must update them by either uninstalling and reinstalling
or using the Client Updater. For more information, refer to the OneStream XF Installation and
Configuration Guide for details in section, “Upgrade or Downgrade via OneStream.”

3. If upgrading from a version 6.0.0 or earlier, it is required that all OneStream Applications complete
the Compile All Business Rules and Formulas to Check for Syntax process as part of the upgrade.
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Scheduling the Upgrade
We recommend that the OneStream Software Technical Support Team performs this upgrade.  Contact
OneStream Technical Support to schedule this upgrade: support@onestreamsoftware.com.

UpgradeGuide 2

Scheduling the Upgrade

mailto:support@onestreamsoftware.com


Pre-Installation Upgrade Checklist
The checklist below details the items that you will complete prior to beginning the upgrade operation.

Step 1: Perform a Full Backup of All OneStream Databases.

Step 2: The App Pool Service Account must use an administrator ID or you must add it to the
PerformanceMonitors User Group, IIS_IUSRS Group and Performance Log Users Group.

Step 3: Download OneStream XF Installation Software from the OneStream XF MarketPlace.

1. Login to the OneStream XF MarketPlace and select Software Download to access the latest version
of OneStream XF.

2. Download the Full Package or Server Software to acquire the appropriate setup files for the server
installation.

Step 4: Verify the location of the OneStream XF configuration files.

1. On each OneStream server, navigate to the OneStream Server Configuration Utility
(Start > Programs > OneStream Software > Server Configuration Utility).

2. Right-click the utility and select Run as Administrator.

3. Choose File > Open ASP.NET Configuration File and browse to C:\Program Files\OneStream
Software\OneStreamAppRoot\OneStreamApp on application servers or C:\Program
Files\OneStream Software\OneStreamWebRoot\OneStreamWeb on web servers, and choose the
web.config file.

4. The web.config will open and display the path to the corresponding configuration files:
XFAppServerConfig.xml and XFWebServerConfig.xml.

5. Copy the config file.

6. Copy and paste the configuration file path in a place that is easily accessible. You will need to re-
enter this information following the upgrade process.

7. Close the file and select No when prompted to save.

8. Close the OneStream Server Configuration Utility.

Step 5: Verify the OneStream service account in Internet Information Services Manager (IIS).

UpgradeGuide 3

Pre-Installation Upgrade Checklist



1. The Service Account must be an Admin ID or in the IIS_IUSRS Group, Performance Log User and
PerformanceMonitor Users groups.
This ID is necessary to use for Queuing and CPUMonitoring.

2. On each OneStream server, launch Internet Information Services Manager
(Start > Control Panel > Administrative Tools > Internet Information Services (IIS)Manager).

3. Expand the server in the left pane and select Application Pools.
This will display a list of application pools in the right pane.  The OneStreamAppAppPool and
OneStreamWebAppPool are displayed in the Identity column.  Keep note of this Windows
account and its password because you will re-enter the information in IIS following the upgrade
process.

Step 6: Verify the OneStream Application Server with the OneStream Database Configuration Utility are
Installed.

On each OneStream application server, navigate to Start > Programs > OneStream Software and verify
which application server has the OneStream Database Configuration Utility installed. You will need to re-
install this on the application server during the upgrade operation.

Step 7: Verify the OneStream Application Server with OneStream Studio is Installed (if applicable).

On each OneStream application server, navigate to Start > Programs > OneStream Software and verify
which application server(s) has OneStream Studio installed.  You will need to re-install this on the
application server during the upgrade operation.
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Pre-Installation Member Object
Rules Evaluation
OneStream XF Version 5.2 introduced a coding changemaking Member Objects Read-Only as part of
regular, ongoing code enhancements.  This changemay cause issues with some existing applications
where business rules are used to create or edit metadata.

This issue can be identified by:

l Analyzing Business Rules for problematic syntax that create or updatemetadata.

l Compiling all Business Rules if errors appear related to read-only objects (after 5.2).

Member Object Application Errors
You can identify this rules error after upgrade by a standard Business Rules compile.  TheMember
Objects will cause an error to display.

The error will also display when the rules are executed through the application.

UpgradeGuide 5

Pre-InstallationMember Object Rules Evaluation



Member Object Identify Problematic Rules
Early rules may have been designed in a manner where theMember object was written-to directly.  This
syntax is no longer valid and is the cause of the compile and application errors.

The Objects related to Member can be viewed using the “IntelliSense” feature, and each will be identified
with their “read-only” status.
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Member Object Rules Solution
The new design of the rule must define the objects while themember is constructed in the rules using
theMember constructor to define theMember variable.  The resulting variable is then used to update
themetadata or metadata properties.

This function contains multiple variations depending upon the use requirements. 

The example below is the common syntax requirement to create a newmember, such as a User Defined
member.

Member( memberPk , Name as String, Description as String, dimID as Integer )

Member Object Updates to Existing Members

A newBRAPI.Finance.Member Business Rule object, WriteableMember, has been created to simplify
managing metadata, optimized to bypass caching for large applications.  The new function retrieves all
themember’s properties as writeable using the ReadWritableMemberNoCache function to allow
updates directly on the object, eliminating the need for a new instance of a member constructor. The
BRAPI.Finance.MemberAdmin function now has new options for SaveMemberInfo to support the
WriteableMember object properties.

Additional no cache functions have also been added to read metadata properties which can be used to
edit current members, or create newmembers. These new functions are
ReadMemberPropertiesNoCache , ReadMemberDescriptionsNoCache , ReadRelationshipNoCache and
ReadRelationshipPropertiesNoCache. The BRAPI.Finance.MemberAdmin function SaveRelationshipInfo
also has new optional properties to directly support updating or creating relationships and properties on
members.

Two new functions have been added to the BRGlobals class which support Business Rule based metadata
management. The Globals.LockObjectForInitialization and Globals.GetOrAddObject are used to ensure
there is proper execution of rules within themulti-threaded rules processes for the checking of the
existence of a member and insertion process. This function ensures these processes all occur within the
same thread lock.

6.0 and earlier:
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l Member Object is Read Only.

l The constructor is used to create the newmembers and any of its properties.

l Existing member objects need to be updated through the constructor, creating a new instance of
the object member.

6.1 and higher:

l You can write directly to a member using theWriteableMember Object.

l The ReadWriteableMemberNoCache function reads a member and returns its properties as
writeable allowing direct updates.

l You can read a member which can be updated.
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6.0 and earlier 6.1 and Higher

BRApi.Finance.MemberAdmin.SaveRelation
shipInfo(si, relationshipInfo,
relationshipPositionOptions)

BRApi.Finance.MemberAdmin.SaveRelation
shipInfo(si, saveRelationship, relationship,
saveEntityRelationshipProperties,
entityRelationshipProperties,
relationshipPositionOptions)

passing in aMemberInfo Object

DimmbrPk AsMemberPk =
BRApi.Finance.MemberAdmin.SaveMember
Info(si, memberInfo, saveMember,
saveProperties, saveDescriptions, isNew)

passing in themember or aWriteable
Member Object

DimmbrPk AsMemberPk =
BRApi.Finance.MemberAdmin.SaveMember
Info(si, saveMember, writableMember,
saveProperties, properties, saveDescriptions,
descriptions, isNew)

DimmbrPk AsMemberPk =
BRApi.Finance.MemberAdmin.SaveMember
Info(si, saveMember, member,
saveProperties, properties, saveDescriptions,
descriptions, isNew)

New functions in the BRGlobals class:

globals.LockObjectForInitialization – This function is needed because Business Rules aremulti-threaded.

It ensures that the check for existence and the insertion both occur within the same thread lock.

If multiple threads are calling this at the same time, this function will return the same object to each
thread (i.e., the one that was added first).

globals.GetOrAddObject –

Dim myObject as New ...

myObject = globals.GetOrAddObject("myKey", myObject)
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Upgrading System Components
The following section describes the process to upgrade the complete OneStream XF system.

Step 1: Stop OneStream Application Pools Prior to Uninstall.

1. On each OneStream server, launch Internet Information Services Manager go to
Start > Control Panel > Administrative Tools > Internet Information Services (IIS) Manager.

2. Expand the server and select Application Pools.
This will display a list of application pools in the right pane.

3. Close any open OneStream Configuration Utilities.

4. Stop the OneStreamAppAppPool and/or OneStreamWebAppPool by right-clicking on each and
selecting Stop.

5. Repeat these steps for each server in the environment.

Step 2: Uninstall the OneStream XF Servers Package.
To upgrade to a new release, the previous software releasemust be uninstalled from all servers before
the new release can be installed on each server in the environment.

1. Navigate to Control Panel > Programs and Features > Uninstall a Program and locate the
OneStream Servers component in the list.

2. Right-click on the OneStream Servers component and select Uninstall.

3. If the OneStream Studio is also installed, locate the OneStream Studio component in the list, right-
click and select Uninstall.

Step 3: Re-Install the OneStream XF Servers Package on an Application Server.

This is the primary OneStream XF installation package. This wizard-based package is used to install a
complete server setup, which includes the web server, application server, and all utilities.  This can also
be used for a custom install, which allows the user to pick and choose the appropriate components for
the server type being built.

1. Browse to the OneStream Servers package, right-click on Setup.exe and select Run as
Administrator to execute the server installation package.
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2. Click Next at the landing page and accept the License Agreement.

3. Select the Custom option and click Next.

4. Choose the installation directory where the software was previously installed and click Next.

5. Choose the Application Server and Server Configuration Utility on the Select Features page and
click Next.

Note:
The Database Configuration Utility may also be chosen if the application server is the
server where the Database Configuration Utility was installed in the previous version of
OneStream XF.

6. Click Install to install the software and click Finish when it is complete.

Step 4: Re-Install the OneStream XF Servers Package on aWeb Server.

1. Browse to the OneStream Servers package, right-click on Setup.exe and select Run as
Administrator to execute the server installation package.

2. Click Next at the landing page and accept the License Agreement.

3. Select the Custom option and click Next.

4. Choose the installation directory where the software was previously installed and click Next.

5. Choose theWeb Server and Server Configuration Utility on the Select Features page and click
Next.

Note: If Mobile is installed, check the Mobile Web Server Option also.

6. Click Install to install the software and click Finish to complete.

Step 5: Re-Install the OneStream XF Studio Package.

1. Browse to the OneStream Studio package, right-click on Setup.exe and select Run as
Administrator to execute the server installation package.

2. Click Next at the landing page and accept the License Agreement.

3. Select the Custom option and click Next.
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4. Select the installation directory where the software was previously installed
(C:\ProgramFiles(x86)\OneStreamSoftware), and click Next.

5. Choose all options on the Select Features page and click Next.

6. Click Install to install the software and click Finish to complete.

Step 6: Upgrade OneStream XF Framework and Application Databases.

Note: Make sure to have the DBA backup all OneStream Databases (Framework/Application
Databases) prior to running the schema update operation.

1. On the OneStream application server with the OneStream Database Configuration Utility installed,
navigate to the utility
Start > Programs > OneStream Software > OneStream Database Configuration Utility.

2. Right-click on the utility and choose Run as Administrator.

3. Right-click on the OneStream Framework Database and choose Upgrade Database Version.

Note: If this is grayed out, an upgrade to the database is not necessary.

4. Confirm the upgrade of the database.

5. Repeat this process for the application database(s) as necessary.

Step 7: Update ASP.NET Configuration File with Configuration File Folder Location.

1. On each OneStream server, navigate to the OneStream Server Configuration Utility
(Start > Programs > OneStream Software > Server Configuration Utility).

2. Right-click on the utility and select Run as Administrator.

3. Choose File > Open ASP.NET Configuration File and browse to C:\Program Files\OneStream
Software\OneStreamAppRoot\OneStreamApp on application servers, or C:\Program
Files\OneStream Software\OneStreamWebRoot\OneStreamWeb on web servers and select the
web.config file.

4. When the web.config opens, paste the Configuration Files Folder path.
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5. Close the file and Save.

6. Repeat this process on each server in the environment.

Step 8: Update Application and Web Server Config Files.

1. Open the Application Server Configuration file and Click File > Save.

2. Close and re-open the Application Server Configuration File.

3. Scroll to Database Server Connections and select the ellipsis (…) icon.

l Update the command Time-outs for the OneStream Database Server Connection:

o Short = 90    *must do

o Large = 900 (minimum of 900)

4. Save and Close the Application Server Configuration file.

5. Open theWeb Server Configuration file.

6. Click File > Save.

7. Close theWeb Server Configuration file.

Step 9: Update the Identity to the OneStream Service Account in Internet Information Services Manager
(IIS) Using OneStream Server Configuration Utility “Configure IIS Tool.”

1. On each OneStream server, navigate to the OneStream Server Configuration Utility
(Start > Programs > OneStream Software > Server Configuration Utility).

2. Right-click on the utility and select Run as Administrator.

3. Choose Tools > Configure IIS.

4. Update the Configure IIS Dialog as follows:
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a. Web Site Name: Enter the name of the OneStream IIS Website to update.

a. OneStream App Server Site

b. OneStreamWeb Server Site

c. OneStream Mobile Server Site

b. Check the “Update IIS Default Settings” box.

c. Set the radio button for updating the appropriate website.

a. Set the radio button to “Use XF Web Server Settings” when updating IIS for the
OneStream MobileWeb Server Site.

b. Set the radio button to “Use XF Web Server Settings” when updating IIS for the
OneStreamWeb Server Site.

c. Set the radio button to “Use XF App Server Settings” when updating IIS for the
OneStream App Server Site.

d. User Account Type: Select Custom Account.

e. Enter the User Name and Password of the OneStream Service Account.

5.) Click the Update IIS Settings button after setting the appropriate fields and click OK.

6.) Repeat this to set the appropriate IIS Settings for the application pools in IIS.

7.) Click the Reset IIS button to perform an IISRESET on the server for the changes to take effect.

Step 10: Test the OneStream Environment Login.

1. Navigate to the OneStreamWeb URL orWindows App URL:
http://<webserver>:50001/OneStreamWeb/OneStreamXF.aspx.
http://<webserver>:50001/OneStreamWeb/OneStreamWindowsApp.aspx.

2. Verify the ability to login to OneStream XF.

3. Select System Administration from the application drop-down list and click Connect.
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4. Navigate to the System tab, Tools > Environment.
This will display a list of all application servers and their server status.

5. Verify each server’s status shows as active and green.

Step 11: Verify the application.

1. Compile ALL Business Rules.

l Right-click the grid and Export any errors for analysis using an Excel file format.

l Apply updates to Business Rules as need.

2. Import new Standard Reports after downloading from the Store on XF MarketPlace.
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